Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 5 Current »

Problem

If you have a configuration that uses multiple threads (NLINK sessions) to process many incoming Messages simultaneously, and you find that the incoming Messages seem to be waiting on Log Message Actions, then you should check the anti-virus settings on the NLINK server machine and exclude the Logs folder and the NLINK Server process from real-time scanning.

Diagnosis

Look at your interface log file(s) from a time when multiple NLINK Sessions are posting to the same log file. If you notice that messages from each session are a second or more apart when they should logically be happening much closer together, this is a symptom. (Normally many messages could be logged within a single second, even from multiple sessions.)

Example of Slow Logging
07-Mar-19 11:33:41 [Session Id   0] [Interface - FOO_BAR] [INFO]    got one
07-Mar-19 11:33:42 [Session Id   1] [Interface - FOO_BAR] [INFO]    got one
07-Mar-19 11:33:43 [Session Id   2] [Interface - FOO_BAR] [INFO]    got one
07-Mar-19 11:33:44 [Session Id   3] [Interface - FOO_BAR] [INFO]    got one
07-Mar-19 11:33:45 [Session Id   4] [Interface - FOO_BAR] [INFO]    got one
07-Mar-19 11:33:46 [Session Id   5] [Interface - FOO_BAR] [INFO]    got one
07-Mar-19 11:33:47 [Session Id   6] [Interface - FOO_BAR] [INFO]    got one


Look at the Inbound Message Queue in the NLINK Management Module (NMM) while multiple NLINK sessions are working on the Events for the same interface. If you notice that the Current Action for the active Events is frequenly a Log Message Action, this is a symptom. (Normally a Log Message should be so quick that it rarely shows up as the Current Action.)

(Note that the entries here show the description of the Action as configured, so you may not see the exact words Log Message.)


Solution

As an example, the following steps describe how to add a Folder Exclusion Rule for the Logs folder and a Process Exclusion Rule for the NLINK Server in Windows Defender on a Windows 2016 Server. 

  1. Open Windows Defender from the System Tray or by searching for the Windows Defender desktop app.
     or 
  2. Click on Settings in the menu bar.
  3. Scroll to the Exclusions section and click Add an exclusion.
  4. Add the NLINK Logs folder as a Folder exclusion and the NLINK Server executable as a process exclusion.

Different operating systems or different anti-virus tools will have different procedures, but all should allow for these sorts of exclusion rules.



  • No labels